QMetry (US) was unresponsive, and users may have received an error message. The system has been restored, and root causes have been identified to prevent future occurrences.
Posted May 20, 2026 - 18:28 UTC
Update
We are continuing to monitor for any further issues.
Posted May 20, 2026 - 17:43 UTC
Monitoring
US QMetry is accessible again, we will continue to monitor for any issues.
Posted May 20, 2026 - 17:19 UTC
Investigating
The US QMetry instance is experiencing a system disruption, and we are investigating the issue.
Posted May 20, 2026 - 16:56 UTC
This incident affected: QMetry - US Cloud (QTM APP US).